We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 15:50 UTC
Identified
GOV+ is experiencing a partial outage with our third-party cache provider, affecting the performance and availability of our services. Users may experience delayed responses or intermittent availability in GOV+ services.
Posted Nov 18, 2025 - 13:55 UTC
This incident affected: Main Website and Dashboard.